Back to overview
Downtime

Mosaic services unavailable

May 19, 2026 at 10:57pm UTC
Affected services
Staff application
Family portal

Resolved
May 20, 2026 at 1:44am UTC

Mosaic functionality has been restored.

Updated
May 20, 2026 at 1:28am UTC

From Railway: We are continuing to work on restoring access to our workloads on Google Cloud. In parallel, our infrastructure team is evaluating alternative paths to bring affected services back online. We do not have an ETA at this time and will continue posting updates as we have them.

Updated
May 20, 2026 at 12:36am UTC

We continue to monitor our hosting service status. They have announced that they are close to resolving the current major outage.

Updated
May 19, 2026 at 11:34pm UTC

We continue to wait for the Railway Service Disruption to be resolved.

Created
May 19, 2026 at 10:57pm UTC

We are investigating a widespread service disruption affecting Mosaic. Users may be experiencing errors including "Your connection is not private", or simply inability to load Mosaic. We have determined that this problem is caused by a service disruption with our hosting platform. They have identified the root cause and are working on a fix.